Slow Calendar Syncing

Incident Report for Quil App and Service Status

Resolved

This incident has been resolved.
Posted Aug 12, 2025 - 20:18 EDT

Identified

We have identified the issue and a fix is being worked on. In the meantime, call schedule may remain delayed by up to 3 hours.

If Quil does not detect a calendar event in time, you can always create a meeting and add a bot manually.
https://help.quil.ai/en/how-do-i-use-quil

We are working hard to resolve this issue. Thank you for your patience.
Posted Aug 12, 2025 - 09:30 EDT

Investigating

We are investigating reports of call slow calendar syncing.
Our metrics indicate a ~4 hour long backlog for meetings to be scheduled.
Posted Aug 12, 2025 - 05:05 EDT
This incident affected: Quil Application.