Delayed Calendar Scheduling

Incident Report for Quil App and Service Status

Resolved

Calendar scheduling is all caught up and back to normal
Posted Oct 07, 2025 - 20:54 EDT

Monitoring

Quil is processing calendar events but is currently 3 hours behind.
Posted Oct 07, 2025 - 17:38 EDT

Identified

Calendar event updates are being scheduled at a slower rate. We have identified the issue and are working on a solution.
Posted Oct 07, 2025 - 14:48 EDT
This incident affected: Quil Application.