Video Call Processing Issues and Failures

Incident Report for Quil App and Service Status

Resolved

This incident has been resolved.
Posted Sep 13, 2025 - 06:33 EDT

Monitoring

A fix has been implemented and we are now monitoring the results. All failed meetings are being reprocessed.
Posted Sep 12, 2025 - 19:21 EDT

Identified

We were alerted to an increased number of calls returning errors which are extending processing times.
We have identified this issue as a problem with one of our sub-processors Recall.ai and are actively engaged with them to resolve it.

For any urgent matters, please don't hesitate reaching out to support@quil.ai
Posted Sep 12, 2025 - 16:16 EDT
This incident affected: Meeting Processing.