Meeting processing appears to be back to normal speed and queues are near empty. We are monitoring the situation to ensure it remains resolved.
Posted Jun 12, 2025 - 16:39 EDT
Identified
Google Cloud Platform is experiencing an outage which is slowing down some analytics requests. In term slowing down critical steps when processing meetings.
Meetings continue to process, be it slowly. Call Analytics will be impacted until the GCP issues are resolved.
Posted Jun 12, 2025 - 15:13 EDT
Investigating
We have been notified of longer than expected meeting processing times and are examining the root cause.