Issues with non-English conversations being transcribed

Incident Report for Quil App and Service Status

Resolved

This incident has been resolved.
Posted Jun 12, 2025 - 20:43 EDT

Monitoring

A fix has been implemented and we are monitoring the results.
Posted Jun 12, 2025 - 08:52 EDT

Investigating

There have been reports of calls not being correctly transcribed to the spoken language. This impacts the quality of notes and follow up material for non English calls. We are actively looking into this issue.
Posted Jun 12, 2025 - 08:27 EDT
This incident affected: Meeting Processing.